
Module 3
IoT Lab Exercises

*Review Appendix for Pre-Lab Setup
** You may want to print Labs to ensure you can follow along during immersion experience



Agenda

• Objectives

• Background

• Lab 1 - Raspberry Pi Basics

• Lab 2 - IoT Basics

• Lab 3 - Azure Basics

• Lab 4 - Data and Analytics Basics



Objectives

• Apply hands on learnings from Module 1 and Module 2 to real world 
IoT and Data & Analytics solutions

• Remove fear and uncertainty of IoT and Data & Analytics solutions

• Simplify jargon and theory to understandable terms and applications

• Deploy an end-to-end IoT real world solution

• Provide an understanding of all roles required to build and deploy an 
IoT and Data & Analytics solution



Background

• A custom image was created for Walsh STEM immersion experience

• The custom image was based off Raspbian Buster Full which is a Linux 
Distros

• In a real world scenario, you will use a different version of Raspbian 
Buster with less programs and packages installed. Additionally, you 
will not have a graphical user interface (“GUI”). This is often referred 
to as headless

• During the labs, your Raspberry Pi will serve two purposes
• Development Machine

• IoT Edge Device



Lab 1
Raspberry Pi Basics



Lab 1
Exercise 1 – Remote into Raspberry Pi



Background

• There are multiple ways to interact with the Raspberry Pi. The most 
common is Secure Shell (“SSH”) 

• In this exercise we will use an SSH client from the terminal on your 
Raspberry Pi

• In real-world scenarios you will use PUTTy (primarily for Windows 
operating systems) or other SSH clients from a remote computer

• In this exercise you will learn to run Linux commands and can 
reference command in the cheat sheets provided in your toolkit



Lab Instructions

1. Click terminal icon       on Raspberry Pi

2. Type ssh pi@walshu-raspberrypi-01 (change highlight based on Raspberry Pi name)

3. Enter password – WalshPi

4. Type yes and Press enter key
a. Note: This step may not be required based on environment

5. Type ls
a. Note: This is a Linux command to list files and folders
b. Note: Repeat this step as often as you would like with other Linux commands (refer to appendix)

6. Type ifconfig
a. Note: wlan0 is your network card with the ip address of your Raspberry Pi. Look for inet 192.x.x.x

7. Type exit
a. Note: You should see logout

8. Type exit to close terminal



Lab 1
Exercise 2 – Sense HAT Emulator



Background

• This exercise is meant to exposure you to python code and simulate 
changing temperature on the Raspberry Pi

• Python is a programming language used for many applications



Lab Instructions

1. Click Raspberry Pi icon       (bottom left of screen)

2. Click Programming > Sense HAT Emulator

3. Click File > Open example > Simple > temperature.py
a. Note: Review the flow and logic of python code

4. Click Run icon 

5. Click Minimize icon 

6. Move temperature scroll bar up and down
a. Note: You should notice the red and blue colors change based on temperature

7. Maximize Thonny application and click Stop icon 

8. Close all windows by clicking X icon



Lab 1
Exercise 3 – Open walsh-stem-iot solution



Background

• This exercise will introduce you to the basics of Visual Studio Code 
and connect Visual Studio Code to Azure to simplify the development 
experience



Lab Instructions

1. Click Raspberry Pi icon       (bottom left of screen)
2. Click Programming > VSCode
3. Click File > Open Folder
4. Click Desktop > Single Click walsh-stem-iot folder > Click OK

a. Note: Close any open windows if they are open

5. Click Select IoT Hub
6. Click Sign In (bottom right of screen)

a. Ensure you use your student username and password
b. Sample: username - stem01@walsh.edu password – RaspberryPi01!

7. Close Browser by clicking X
8. Select Az Sub 1 in VSCode
9. Select walsh-stem-iot-iothub

mailto:stem01@walsh.edu


Lab 2
IoT Basics



Lab 2
Exercise 1 – Raspberry Pi Simulator



Background

• We will use a Raspberry Pi simulator to show how to blink a led and 
send temperature data to Azure

• You will learn to navigate Azure and the Azure IoT Hub

• All code is written in Node.js and stored on GitHub

• The hardware in this lab could easily be added to your physical 
Raspberry Pi



Background

1. Assembly area - The default circuit is 
that a Pi connects with a BME280 
sensor and an LED. The area is locked 
in preview version so currently you 
cannot do customization.

2. Coding area - An online code editor 
for you to code with Raspberry Pi. 
The default sample application helps 
to collect sensor data from BME280 
sensor and sends to your Azure IoT 
Hub. The application is fully 
compatible with real Pi devices.

3. Integrated console window - It shows 
the output of your code. At the top 
of this window, there are three 
buttons.



Lab Instructions

1. Navigate to Azure Raspberry Pi Simulator
a. https://azure-samples.github.io/raspberry-pi-web-simulator/

2. Navigate to Azure Portal in new tab or additional browser window
a. https://portal.azure.com
b. Login with your Walsh provided student username and password

3. Get IoT device connection string from Azure Portal
a. Click Resource Groups > walsh-stem-iot-rg > walsh-stem-iot-iothub
b. Under Automatic Device Management, click IoT Edge
c. Click your IoT device
d. Click copy icon       next to Primary Connection String

4. Paste your connection between ' ' (highlighted below) on line 15
a. const connectionString = '[Your IoT hub device connection string]';

5. Click Run

https://azure-samples.github.io/raspberry-pi-web-simulator/
https://portal.azure.com/


Lab 2
Exercise 2 – Raspberry Pi end-to-end solution



Background

• This exercise will show you how to update python code and deploy 
the updated code to your Raspberry Pi

• In real world scenarios, the device can exist anywhere in the world 
and you can follow a very similar process to deploy updates to 
specific devices



Lab Instructions

1. Follow Steps from Lab 1 – Exercise 3

2. Expand EdgeSolution > Modules > ReceiveMessageModule

3. Click main.py

4. Goto line 17 and paste your connectionstring
a. To get your connection string, right click your device 

b. Click Copy Device Connection String

c. Note: connectionstring goes between “paste here”

d. Tip: delete between “ ” then right click and click paste

5. Click module.json
a. Update line 7 to 1.[device number].1 



Lab Instructions

6. Expand EdgeSolution > Modules > ButtonModule

7. Click main.py
a. Note: Review python code

8. Goto line 66

9. Change highlighted section below to your name
a. message.custom_properties["studentName"] = "Student1“

10. Click module.json
a. Update line 7 to 1.[device number].1 



Lab Instructions

11. Expand EdgeSolution > Modules > VibrationModule

12. Click main.py
a. Note: Review python code

13. Goto line 63
a. Repeat for line 91

14. Enter your name between “ “ (highlighted below)
a. message.custom_properties["studentName"] = "Student1“

15. Click module.json
a. Update line 7 to 1.[device number].1 



Lab Instructions

16. Click File Save All

17. Right click deployment.template.json
a. Click Build and Push IoT Edge Solution



Lab Instructions

18. Expand Edge Solution > config

19. Right click deployment.arm32v7.json
a. Click Deployment for Single Device

b. Important: Select your Raspberry Pi

20. Click Terminal icon 

21. Type docker ps -a
a. Look for ReceiveMessageModule

b. Status should be up X seconds or minutes

22. Type docker logs ReceiveMessageModule -f



Lab Instructions

23. Click Minimize icon

24. Right Click your device
a. Click Send C2D Message to Device

b. Note: C2D = Cloud to Device  

25. Type hello from the cloud

26. Click open Terminal from bottom taskbar
a.

b. Note: you should see your message

27. Click X to close Terminal



Lab 2
Exercise 3 – Send IoT Messages to IoT Hub



Background

• IoT devices can have multiple sensors for specific user cases

• In this exercise we will simulate a machine that requires maintenance 
after a certain number of presses

• There are multiple ways to monitor messages going to and from IoT 
devices

• In this exercise you will send messages to Azure and monitor Built-in 
Event endpoints



Lab Instructions

1. Follow Steps from Lab 1 – Exercise 3
a. Note: Skip if you completed Lab 2 Exercise 2

2. Right click your device 

3. Click Start Monitoring Built-in Event Endpoint

4. Push button or Use vibration sensor
a. Note: you are simulating a machine stamping or 

a machine vibrating

b. Note: push button multiple times

c. Note: hold button down to see variations in data

d. Note: you should see data in output window



Lab 2
Exercise 4 – Invoke Module Direct Method



Background

• In this exercise you will set the value remotely when your device 
should alert you of a temperature issue



Lab Instructions

1. Follow Steps from Lab 1 – Exercise 3
a. Note: Skip if you completed Lab 2 Exercise 2

2. Expand your device > Modules

3. Right click ButtonModule
a. Click Invoke Module Direct Method

b. Type SetTemp

c. Press Enter

d. Type 40

e. Press Enter



Lab Instructions

4. Press button sensor

5. Review output window 
a. You should notice the temperature you set

b. Note: Based on timing, instructors will show PowerBi dashboard and your 
device should have an alert



Lab 3
Azure Basics



Lab 3
Exercise 1 – Add Temperature Module



Background

• The Azure marketplace has modules that can be deployed to your IoT 
device

• In this exercise, we will simulate a temperature sensor on your IoT 
device



Lab Instructions
1. Navigate to Azure Portal in browser window

a. https://portal.azure.com
b. Login with your Walsh provided student username and password

2. Deploy Module from Azure Portal
a. Click Resource Groups > walsh-stem-iot-rg > walsh-stem-iot-iothub
b. Under Automatic Device Management, click IoT Edge
c. Click your IoT device
d. Click Set Modules
e. Click Add Marketplace Module
f. Type temperature in search
g. Click Simulated Temperature Sensor
h. Click Review and Create > Create

3. Run docker ps -a on raspberry pi

https://portal.azure.com/


Lab Instructions
4. Run docker logs SimulatedTemperatureSensor -f

5. Remove Simulated Temperature Sensor
a. Click Set Modules

b. Click trash icon            by Simulated Temperature Sensor

c. Click Review and Create

d. Click Create



Lab 3
Exercise 2 – Create IoT Hub



Background

• Azure has over 200 services that be easily be deploy through the 
portal

• In this exercise you will learn how to create an IoT Hub very similar to 
what you been using for the labs

• In your free time ☺, you should sign-up for a free Azure account and 
connect your raspberry pi to your Azure IoT Hub
• Additionally instructions and labs will be created in future to assist with end 

to end setup



Lab Instructions
1. Navigate to Azure Portal in browser window

a. https://portal.azure.com
b. Login with your Walsh provided student username and password

2. Deploy IoT Hub from Azure Portal
a. Click Resource Groups > walsh-stem-iot-rg
b. Click Add
c. Type IoT Hub
d. Select IoT Hub by Microsoft (image to right)
e. Click Create
f. Enter walsh-stem-iot-iothub-student01
g. Click Size and scale
h. Choose F1: Free tier for Pricing and scale tier
i. Click Review + create
j. Click Create

https://portal.azure.com/


Lab 4
Data and Analytics Basics



Lab 4
Exercise 1 – Visualize IoT data with PowerBi Desktop



There are 4 main categories of analytics

Descriptive

Diagnostic

Predictive

Prescriptive

(What happened)

(Why it happened)

(What will happen)

(What actions to take)

Complexity

V
al

u
e



Two fundamental terms

Measures Dimensions



List your big questions: 

1. What is my Total Sales for a Selected Year and Region?

2. How is my Total Sales doing Year Over Year?

3. How are my Units trending for various States in my region?

4. How is my Sales doing by Channel, Device, Category for selected Year?

5. Which categories are performing best to worst by Total Sales ?

Convert the story to a data model

Units
Total Sales
Gross Profit

These are 
Attributes that live 
in Dimension tables

By Time (Year, Month)
By Geography (Region, State or City)
By Campaign (Channel or Device)

These are Measures
which live in Fact

tables



Data Visualization Process
Learn about your 
audience needs

Rapid 
Prototype

Build visuals in tool

User Feedback

User Feedback

Who? Where?

What?  How Many?

When? Why?  



Layouts



Choosing the right chart for the right purpose

Water Fall

100% Stacked Column

Tree

Bubble

Scatter PlotStacked Bar

Clustered Bar

Clustered Column

Map

Map

Stacked ColumnTable

Matrix

Line

Funnel

Line and Stacked Column

Area

Stacked Area

Filled Map

KPI

GaugePie Bubble

Multi-row Card

Card



Dashboard layout
MAIN KPIs

INDICATORS

KPIs DETAILS

PROPORTIONS

SSA TIER 2



MAIN KPIs

KPIs DETAILS

INDICATORS

PROPORTIONS

SSA TIER 2



Lab Instructions

1. Click on Get Data in the Home tab

2. Select Azure  

3. Select Azure Cosmos DB 

4. Click Connect



Enter data base 
URL 

Lab Instructions

5. Enter the URL for the database
https://walsh-stem-iot-cosmosdb.documents.azure.com:443/

6. Enter the Account key

coCbX3hLmzVwxv9ZbJ85Ay4aF8tSlaHOfHtTFHK3f8da9cOzZ5Opyjhw7COJMj55xEN0UauGD83vw3eyNIhOXA==

https://walsh-stem-iot-cosmosdb.documents.azure.com/


Check 
“IoTCollection”

Select “Load”

Lab Instructions

7. Check IoTCollection

8. Click Load  



Lab Instructions

9. Click on card to show KPI 10. Select the field to 
show the KPI



Lab Instructions

11. Click on “Stacked 
bar chart”

12. Select the fields 
”Document Sensor” and 
“Document.device_id”

Drag and drop 
the field into 
“Axis” and 
“Value”



Power Bi Resource
Contact Support 

Report Errors, Issues – Support.PowerBI.com

Resources
➢ Community.PowerBI.com – Community Forum

➢ Report Theme Gallery – A showcase for stunning report themes

➢ Data Stories Gallery – Get inspired with Data Stories by other Power BI users

➢ R-Visuals Gallery – Get inspired by others use of R for analyzing their data

➢ Store.office.com – Custom PBI visuals and R visuals you can download and use in your story

➢ Power BI Blog - weekly updates

➢ User Voice for Power BI – Vote on (or submit) your favorite new ideas for Power BI

➢ Issues.PowerBI.Com – log issues with the community

➢ Whitepaper - Creating an Enterprise Class Dashboard Solution with Power BI

➢ Guided Learning Self Service Power BI training

➢ DAX Formula Language – syntax for DAX
➢ DAX Patterns – Great website to learn new patterns for the DAX Language
➢ Power Query Formula Language – syntax for the “Query” language
➢ Paletton.com – a color scheme generator
➢ https://unicode-table.com/en/ – Unicode Character Table
➢ Theme Generator
➢ Contrast Analyzer: a tool that creates a “lens” to show how people with different visual disabilities might see your reports

➢ Charticulator: a tool that helps to build custom visuals

http://support.powerbi.com/
http://community.powerbi.com/
https://community.powerbi.com/t5/Themes-Gallery/bd-p/ThemesGallery
http://community.powerbi.com/t5/Data-Stories-Gallery/bd-p/DataStoriesGallery
http://community.powerbi.com/t5/R-Script-Showcase/bd-p/RVisuals
https://store.office.com/en-us/appshome.aspx?productgroup=PowerBI
http://blogs.msdn.com/b/powerbi/
http://ideas.powerbi.com/
http://issues.powerbi.com/
http://issues.powerbi.com/
http://aka.ms/bapidashwp
https://powerbi.microsoft.com/en-us/guided-learning/
https://docs.microsoft.com/en-us/dax/dax-function-reference
http://www.daxpatterns.com/
https://docs.microsoft.com/en-us/powerquery-m/power-query-m-function-reference
http://paletton.com/#uid=1000u0kllllaFw0g0qFqFg0w0aF
https://unicode-table.com/en/
https://powerbi.tips/tools/report-theme-generator-v3/
https://developer.paciellogroup.com/resources/contrastanalyser/
https://charticulator.com/


Appendix



Pre-Lab Setup

1. Plugin mouse into keyboard and keyboard into black usb on 
Raspberry Pi

2. Plugin micro-HDMI into Raspberry Pi and HDMI into monitor or tv

3. Plugin power into Raspberry Pi and into power outlet

4. Connect to home wifi (bottom right click on wifi icon        )

5. Prepare Lab Day via Option 1(preferred setup) or Option 2 (ensure 
you print labs)

*Walsh IT Department will be available for consultation prior to start of program with questions and to 
confirm system requirements and proper set-up. Call Help Desk at 330-244-4357 or helpdesk@walsh.edu
** Watch Video setup from the following url https://www.walsh.edu/skilled-tech-requirements.html

mailto:helpdesk@walsh.edu
https://www.walsh.edu/skilled-tech-requirements.html


Lab Day – Setup Option 1

• Preferred Setup with external monitor or TV

• Raspberry Pi is connected to external monitor or TV

• Laptop will be connected to Zoom call



Lab Day – Setup Option 2

• Use this option only if you do NOT have an external monitor
• Laptop is connected to Zoom
• Laptop is connected Raspberry Pi via VNC viewer*

• Enter walsh device id(label on side of Raspberry Pi) into VNC viewer

• Raspberry Pi is connected to power outlet

https://www.realvnc.com/en/connect/download/viewer/

https://www.realvnc.com/en/connect/download/viewer/
https://www.realvnc.com/en/connect/download/viewer/


Linux Commands
Command Description

ls The ls command lists the content of the current directory (or one that is 
specified). It can be used with the -l flag to display additional information 
(permissions, owner, group, size, date and timestamp of last edit) about each file 
and directory in a list format. The -a flag allows you to view files beginning 
with . (i.e. dotfiles).

cd Using cd changes the current directory to the one specified. You can use relative 
(i.e. cd directoryA) or absolute (i.e. cd /home/pi/directoryA) paths.

pwd The pwd command displays the name of the present working directory: on a 
Raspberry Pi, entering pwd will output something like /home/pi.

mkdir You can use mkdir to create a new directory, e.g. mkdir newDir would create the 
directory newDir in the present working directory.

rmdir To remove empty directories, use rmdir. So, for example, rmdir oldDir will remove 
the directory oldDir only if it is empty.

rm The command rmremoves the specified file (or recursively from a directory when 
used with -r). Be careful with this command: files deleted in this way are mostly 
gone for good!

cp Using cp makes a copy of a file and places it at the specified location (this is 
similar to copying and pasting). For example, cp ~/fileA /home/otherUser/ would 
copy the file fileA from your home directory to that of the 
user otherUser (assuming you have permission to copy it there). This command 
can either take FILE FILE (cp fileA fileB), FILE DIR (cp fileA /directoryB/) or -r DIR 
DIR (which recursively copies the contents of directories) as arguments.



Linux Commands
Command Description

mv The mv command moves a file and places it at the specified location (so 
where cp performs a 'copy-paste', mv performs a 'cut-paste'). The usage is similar 
to cp. So mv ~/fileA /home/otherUser/ would move the file fileA from your home 
directory to that of the user otherUser. This command can either take FILE 
FILE (mv fileA fileB), FILE DIR (mv fileA /directoryB/) or DIR DIR (mv /directoryB
/directoryC) as arguments. This command is also useful as a method to rename 
files and directories after they've been created.

cat You can use cat to list the contents of file(s), e.g. cat thisFile will display the 
contents of thisFile. Can be used to list the contents of multiple files, i.e. cat 
*.txt will list the contents of all .txt files in the current directory.

tail The opposite of head, tail displays the end of a file. The starting point in the file 
can be specified either through -b for 512 byte blocks, -c for bytes, or -n for 
number of lines.

scp The scp command copies a file from one computer to another using ssh. For more 
details see SCP (secure copy)

sudo The sudo command enables you to run a command as a superuser, or another 
user. Use sudo -s for a superuser shell. For more details see Root user / sudo

https://www.raspberrypi.org/documentation/remote-access/ssh/scp.md
https://www.raspberrypi.org/documentation/linux/usage/root.md


Docker Commands
Command Description

docker ps -a Lists of all existing containers (not only running)

docker stop $(docker ps -a -q) Stop all running containers

docker rm $(docker ps -a -q) Delete all existing containers

docker rmi $(docker images -q -a) Delete all existing images

sudo docker exec -i -t 878978547 bash Attach to a running container

docker logs -f 878978547 Using Docker logs command

*change highlighted section based on your container. Use docker ps –a to see the ID


